CMS

Проблема с weblinks в 1.0.8 Joomla

Суть проблемы:

В главном меню есть пункт Ссылки (доступ: Public). Там ссылки с сайта разбиты по разделам + кое-какие комментарии. После обновления с 1.0.5 до 1.0.8 не могу попасть в этот раздел. Причём, совершенно не важно, зарегистрирован я или нет (логин под пользователя admin ситуацию не исправляет). Т.е. ссылки не доступны ни на при просмотре гостем ни при зарегистрированном пользователе. Компонет com_weblinks (стандартный, что шел с версией 1.0.5). Пришлось снять с публикации пункт в меню.

!!! Замечено также, что если в настройках сайта разрешить показ неавторизированных ссылок, то почему-то становятся доступны пункты из Usermenu, доступ к которым только Registered. Проблема всплыла у меня, не знаю как  у других. Разрешением показа неавторизированных ссылок проблема с Weblinks не решилась.

Ну и конечно, как и у всех, в модуле login видим "Здравствуйте, 0".

Ждём заплаток Или хотя бы разъяснений где и чего искать.

цитата из: mr. Raven на Март 09, 2006, 03:03:39 pm
цитата из: AndyR на Март 09, 2006, 07:42:10 pm
цитата из: mr. Raven на Март 09, 2006, 03:03:39 pm
> "Здравствуйте, 0"

В новых версиях движка изменена система авторизации по кукам.
т.е. движок не сразу признает посетителя, а только после какой то (не считал) попытки или что-то около этого.
Я не разбирался с этой новой технологией, но могу посоветовать поробовать следующее:

- попробуйте изменить "Общие настройки" -> "Сервер" -> "Метод авторизации сесии"

 
'метод авторизации сесии' не помогает.. 
На этой неделе собираюсь выпустить патч по этой проблеме...
   
У меня тоже была эта проблема с mod_login (Здравствуйте, 0). Решил её просто - в настройках mod_login исправил, что выводить. Поменял настройку Имя/Псевдоним на Имя, и всё заработало, начали выводиться ники. Правда я так понимаю это неправильно, потому что по идее должно выводиться Имя пользователя.
Поставил патч, но проблема с доступом на просмотр "ссылок" осталась : -[ пишет, как и писал "У Вас нет прав для просмотра этого ресурса.
Вы должны зайти как пользователь. ", а стоит везде "Public" Как быть то.
Попробуйте переустановить пакет, зафдите на http://demo.joomlaportal.ru и посмотрите там... Там все работает...
как переустановить сам компонет weblinks? если я его удалю из компонетнов?
А зачем удалять то, просто отключите у него публикацию...
Решил проблему со ссылками.

При заходе из меню (у меня mainmenu) в раздел с сылками отображется сообщение "нет прав на просмотр ресурса", необходимо в админке _удалить_ пункт меню (у меня он называется, как это ни странно, "Ссылки" ), и создать его заново. В качестве цели для ссылки рекомендую выбрать "Компонет". Затем, нажав "далее", выбрать компонет "Ссылки". Всё заработает.

P.S. Проблема с login, благодаря патчу решилась. Спасибо!
P.P.S. Какой смысл переходить на 1.0.9 ?
цитата из: mr. Raven на Март 16, 2006, 10:57:18 am
цитата из: mr. Raven на Март 16, 2006, 10:57:18 am
у меня такая же проблема, на сайте по админу вводишь урл и т.д. он то вносится в таблицу, но на сайте не отображается (, я уже делала через создание нового раздела, как описано выше.. стали только катео=гории отображаться, а неавторизаванных ссылок все равно не показывает.. т.е. каждый раз надо самой все публиковать в адм панеле ((, как все сделать ?
Кто-то писал (я сам с такой проблемой не сталкивался) что ему помогдо удаление всех существующих ссылок, категорий и разделов и создание всего дерева и ссылок в нем заново. Говорит, что после этого все заработало...

Я , к сожалению, не могу проверить это, т.к. у меня этот деффект не проявляется.