CMS

Вопросы по Joomla 1.0.х RUS Paranoia

Здесь задаются вопросы по сборкам версий "Joomla 1.0.х RUS Paranoia"
Буду первым =)

Андрей, и другие не менее уважаемые жумлеры!
Взываю к помощи!

Столкнулся с проблемой: поставил на новый хостинг 1.02 RUS Paranoia mysql40

Не могу установить ни одного модуля и компонента, говорит что не находит XML файл (проверял пакеты и файлы в порядке)

ОШИБКА: Не могу найти XML установочный файл в пакете.
Установочный файл не найден:
public_html/media/install_43629703f0c46/


походу не может записать распакованный модуль-компонент в media/цифрыбуквы/

такое ощущение что что то в пермишнах =( но везде выставлял 777

может дело в том что SAFE MOD? или что tmp директория не прописана в httpd? или в

Поборол. дело было в сейф моде конечно
Наконец то я смог спросить
С Мамбой проблем не было. А с Юмлой - есть. Не могу проинсталировать. Чистый экран после запуска и всё. Причем в HTML коде этой "пустой" страницы имеется совет убрать инсталяционный каталог
Если его убрать, то появляется приглашение войти в сайт. Но ведь таблицы в базе данных не созданы!
Что я не так сделал?

Ребята! Научитесь корректно описывать создавшуюся проблему!

Софт? Версии? Условия? Что сделано, а что нет? Как шла установка? На каком этапе и что произошло?

А то часто вопросы похожи на: "Я включил, а она не хочет! Что может быть?"

Вот по вашему вопросу попробуйте сами ответить... Чистый экран после запуска чего?

Отвечаю (каков вопрос, таков и ответ): Включите монитор...
Хорошо, попытаюсь 
Я использую в своей работе сервер, который в локальной сети фирмы и который работает под юниксом. Вот информация о системе:
PHP сборка:  FreeBSD blues.add.com 4.3-RELEASE FreeBSD 4.3-RELEASE #15: Sun Au i386 
База данных - версия:  3.23.51 
PHP версия:  4.3.1 
Web сервер:  Apache/1.3.12 (Unix) PHP/4.3.1 
WebServer to PHP интерфейс:  apache 
Я создал базу данных в MySQL и назначил ей соответствующие права тем самым. Скопировал файлы из архива Джумля joomla_102_rus_paranoia_mysql_40.zip в папку на сервере. Скажу прямо - в этой папке когда-то лежали файлы от Мамбо и все работало.
После этого я отредактировал файл конфигурации, указав в нем пользователя (root), пароль и имя базы данных. Таким вот образом:
$mosConfig_offline = '0';
$mosConfig_host = 'localhost';   // This is normally set to localhost
$mosConfig_user = 'root';         // MySQL username
$mosConfig_password = 'хххх';      // MySQL password
$mosConfig_db = 'joo';            // MySQL database name
$mosConfig_dbprefix = 'jos_';   // Do not change unless you need to!

$mosConfig_lang = 'english';            // Site language
$mosConfig_absolute_path = '/usr/home/add/b.add.com';   // No trailing slash
$mosConfig_live_site = 'http://b.add.com';   // No trailing slash
$mosConfig_sitename = 'Joomla';            // Name of Joomla site

Ну и запустил http://b.add.com
в своем IE 6.0 от доблестной честной компании.

Результат - никакой. Т.е. Чистая страничка, никаких сообщений. Просмотрел HTML код (не нравится мне это словцо) и увидел предложение убрать папку с инсталляционными файлами. Попробовал убрать и повторить попытку. На этот раз увидел предложение ввести логин и пароль. Но в базе данных - ни одной таблицы созданно не было.
Вот и думаю, так сказать, чешу затылок - что я сделал не так или что у меня было сделано не так. Завтра куплю CD с более свежей операционкой для сервера. Может причина здесь?


Таблицы БД создаются в процессе инсталляции. Вы этот процесс не запускали. С чего вы хотите , чтобы что-то вообще работало?
"Мусор на входе - мусор на выходе"

Если инсталляция новая:

- Удалите ВСЕ из каталога, где будет стоять Джумла;
- скопируйте туда дистрибутив;
- ничего не редактируйте, а наберите WWW-адрес этого каталога (запустится процесс инсталляции);
- следуйте указаниям инсталлятора.

Если обновление Мамбо до Джумлы:

- выполните над БД SQL-файл - "installation__sqlmigrate_Mambo4523_to_Joomla_тру-ля-ля.sql";
   Это модифицирует существующую БД под формат Джумлы (после этого БД станет несовместимой с Мамбо!);
- скопируйте ВЕСЬ дистрибутив поверх существующей Мамбо;
- зайдите в админку проверьте все настройки, установку шаблонов и т.п.

Шаблоны Джумла несовместимы с шаблонами Мамбо, веринее - требуют модификации!!!


Спасибо премногое. Дело было в том, что я правил сам конфигурационный файл.
Да, ещё маленькая деталь - после установки после URL сайта оказалось два слэша. В конфиге подправил - все стало на свои места.
Теперь вопрос вам: Что лично вам ближе к сердцу, Мамбо и Джумла?
С благодарностью, Сергей.

Я рассматриваю Джумлу просто как проодолжение линейки Мамбо, фактически как смену имени.
А как сделать, что бы "джумла" в показывала URL в браузере (простите за ругательное слово) типа:http://andyr.mrezha.ru/smf/index.php?action=post;topic=73.0;num_replies=8 , а не типа http://a.add.com/index.php?option=com_frontpage&Itemid=1 ?
А никак.
Символ ? является указателем, что дальше идут параметры "командной строки".
Символ & является разделителем параметров.

Параметры передаются по правилу: имя_параметра = значение параметра

Это является стандартом и ни от Мамбо ни от Джумлы не зависит.

А есть ли возможность сделать так, что бы в строке браузера показывалась строка на html файл.  Как в "нюке"?
А в этой системе нет никаких html-файлов. Строка броузера остается или такой, какаяы она есть сейчас или включается SEF - дружественные ссылки.
Понятно.
Никак не можем поставить GZIP на сервер. Вернее - поддержку для "джумлы".
Жуть какая то... Наш локальный сервер уже работает много лет и проблем не было. Теперь, когда я пытаюсь проинсталлировать компонент в зазипованом виде, то появляется сообщение, что GZIP не поддерживется или не разрешен.